If you're not using the most recent version of your browser, your private information isn't as safe as it could be. Older browsers don't have the latest security features that keep your information safe when you're using the internet. They use outdated versions of what are called Transport Layer Security (TLS) protocols. TLS aims to prevent fraud by providing secure communications on the web.

That's why we can only fully support browsers that meet the latest standard, TLS version 1.2. If you use an outdated browser after September 15, 2019, you won't be able to visit and do business on Sun Life websites from your desktop or mobile device.

Updating your system

To make sure your system supports TLS 1.2, you may need to do one or more of the following:

  • Update your web browser to the latest version for your system: Chrome, Firefox, Internet Explorer, or Safari.
  • Enable TLS 1.2 in the current version of your browser.
  • Update your operating system – Windows or Mac OS – to the latest version for your computer
  • Upgrade your computer or other devices you use to connect to the internet.

If you have questions or concerns about this issue, please visit our contact us page.